Denodo community Q&A RSS feed Latest Denodo community questions MongoDB Atlas (through AWS) Hello, I'm trying to connect a MongoDB Atlas cluster from Denodo through the mongodb-customwrapper. Reading the user manual about this custom wrapper, it seems to me that ony clusters "based" on Azure can connect to Denodo. It is correct? I'm using a cluster "based" on AWS and I can't connect with this custom wrapper.. there is a way to connect thi AWS based cluster on MongoDB Atlas from Denodo? Am I missing something? Thanks, Maria B. Wed, 17 Apr 2024 08:20:05 GMT 2024-04-17T08:20:05Z require guidance on creating new views in Denodo require guidance on creating new views in Denodo. We are aggregating data from old and new version of RAMOS (basically from two databases) into one source domain and building views on top of that for our downstream systems to consume. Can you suggest the right approach and what all do we need to do in order to achieve this business objective? Mon, 15 Apr 2024 08:19:13 GMT 2024-04-15T08:19:13Z first of current year how do I pull first of current year and forward? for example, when the date is currently 1/1/24 to 12/31/24, I always want to get results from 1/1/2024 and forward. Fri, 12 Apr 2024 17:41:24 GMT 2024-04-12T17:41:24Z remote table Question 1: does Denodo express 8.0 has this remote table feature. Question 2: in licensed version of Denodo 8.0, can remote table fetaure write data to AWS S3 bucket. Question 3: in licensed version of Denodo 8.0, can remote table write back data to a DB for any view (base view , derived view). or there is any limitation. note: URGENT. please answer. Thanks. Thu, 11 Apr 2024 11:55:31 GMT 2024-04-11T11:55:31Z Unexpected error creating a connection hi team, When attempting to connect to the data source, we encountered an error. Could you please advise on the potential issue and provide a solution? Unexpected error creating a connection: Failed to authenticate the user in Active Directory (Authentication=ActiveDirectoryPassword). Thnak you. Thu, 11 Apr 2024 07:37:36 GMT 2024-04-11T07:37:36Z How to deal with BLOB in Denodo? Hello Team, I have a situation that I imported a base view from SAP table. But there is a column which data type is RAW in SAP. After creating base view in Denodo, the type of such column convert to BLOB. If I use cast('text',column) when creating derived view based on the base view, the result of such column is garbled. Does the issue come from decoding? Should I complete any special configurations to restrict charset when creating data source? How can I convert such BLOB to a text in order to use the column to join with other views? And in which layer I should convert the data type? Thanks. Thu, 11 Apr 2024 03:07:28 GMT 2024-04-11T03:07:28Z Allow logging all received requests in the Scheduler REST API. As mentioned in the enhancementâ?¯#78114, we can now add logger to all received requests in the Scheduler Rest API. How can we configure this functionality ? And for the logs, are they stored in files ? Thanks Wed, 10 Apr 2024 18:22:27 GMT 2024-04-10T18:22:27Z Unable to connect to vdp services with CSRF token validation errors denodo 06:24:27.43 INFO ==> ** Starting Design Studio ** [SSO] 6320 [RMI TCP Connection(2)-] INFO 2024-04-10T06:24:35.307 [] - Starting DenodoSSOWebApplication v8.0.7 using Java 11.0.8 on designstudio-1 with PID 629 (/opt/denodo/resources/apache-tomcat/webapps/sso/WEB-INF/classes started by denodo in /opt/denodo/resources/apache-tomcat/bin) [SSO] 6332 [RMI TCP Connection(2)-] INFO 2024-04-10T06:24:35.319 [] - No active profile set, falling back to 1 default profile: "default" [SSO] 8932 [RMI TCP Connection(2)-] INFO 2024-04-10T06:24:37.919 [] - Started DenodoSSOWebApplication in 3.346 seconds (JVM running for 8.975) denodo 06:24:53.00 DEBUG ==> ** Waiting for PID 629 ** [DS] 849263 [https-jsse-nio2-9443-exec-2] ERROR 2024-04-10T06:38:38.250 [] - Access denied for https://denodo-domain:9445/denodo-design-studio/login?isWebLogin=false caused by Could not verify the provided CSRF token because no token was found to compare. Wed, 10 Apr 2024 07:11:59 GMT 2024-04-10T07:11:59Z Unable to deploy REST web service Hello, I am working on creating a REST Web Service and am trying to deploy the web service but I am getting the error: "web service was not successfully deployed by the web container". We did review the vdp.log file and didn't find additional information for the cause of this issue and try dropping and recreating the REST web service. I still get the same error after testig that. Do you have any suggestions of what the cause could be for this error? Thanks Tue, 09 Apr 2024 15:10:04 GMT 2024-04-09T15:10:04Z Can you query the cache for invalid or expired rows Is it possible to query the cache of a view for the invalid or expired rows before you run the cache cleanup? Tue, 09 Apr 2024 14:30:39 GMT 2024-04-09T14:30:39Z