You can translate the question and the replies:

query timeout issue

Hi , I have made a snowflake data source connection and created a base view on top of it which has a total of 1988 records . when i'm using a simple select * to execute my base view , it gives results instantly for 150 rows , but when i check the include all rows box while executing it gives me this error : Finished with error: Error executing query. Total time 100.034 seconds. BV_LABSPACEASSESSMENT [BASE] [QUERY_TIMEOUT] LAB_SPC_ASSESSMENT [JDBC WRAPPER] [PROCESSING] LAB_SPC_ASSESSMENT#0 [JDBC ROUTE] [PROCESSING] kindly help.
15-03-2023 03:52:40 -0400

1 Answer

Hi, It looks like your default query timeout is 100 seconds. By default, Denodo has a 900-second or 15-minute query timeout. This can be checked and configured in different ways. **Changing your Design Studio Preferences** This option changes the default query timeout for all Design Studio users. You can access the configuration through the endpoint: `https://<denodo_server>:<port>/denodo-design-studio/#/web-local-login` For step-by-step instructions and more details, you can check this [User Guide]( **Using CONTEXT on your VQL queries** You can add a QUERYTIMEOUT context clause in your VQL queries if you want to override the default query timeout without changing the configuration. You need to set the query timeout in milliseconds. *Ex:* SELECT \* FROM bv_labspaceassessment **CONTEXT ('QUERYTIMEOUT'='900000')** To learn more details about other CONTEXT clauses, you can see this [User Guide]( Hope this helps!
Denodo Team
16-03-2023 23:12:56 -0400
You must sign in to add an answer. If you do not have an account, you can register here