You can translate the question and the replies:

CONTECT('cache'= 'off') is not fetching data from sources

Hi Team, I'm using Denodo 7.0. I have a derived view dv_join which has several intermediate views. Full cache mode is enabled for this view and Oracle is the cache DB. Loading the cache for this view is taking around 1 hour to complete. I want to see the plan using it for loading the cache. when i ran below query and seen the execution trace, its showing the plan for data retrieved from cache DB. But when i pass parameter 'off' in context clause, ideally it shouldn't use cache and should fetch the data from datasources directly. Further, i must see the plan for fetching the data from sources in Execution trace. SELECT * FROM bv_join CONTEXT('cache'='off') Please help.
06-05-2021 10:15:58 -0400

1 Answer

Hi, I am able to force the Execution Engine to retrieve data from the source by disabling the cache with Context(‘cache’=’off’) as described in the [Context Clause]( section of the Virtual DataPort VQL Guide. Alternatively, I can graphically select the ‘Do Not Use Cache’ checkbox in the Execution Panel in Virtual DataPort Administration tool to disable the cache for that execution. The QueryPlan will visually reflect the change in the data sources with the Cache disabled, and you can visually confirm whether the Cache is being used or not. If you are a valid support user, you can open a Request at the [Denodo Support Site](, so that our Support Team can assist you. Hope this helps!
Denodo Team
06-05-2021 18:15:10 -0400
You must sign in to add an answer. If you do not have an account, you can register here