You can translate the question and the replies:

After enabling HTTPS can't connecto to virtual data port server nor webtools

Hello, I was doing the exercise of the DEN80EDU13DS05 module to enable the HTTPS in and server.xml and did everything as was shown. But after I start the servers VDP server can be started, but it does not connect to server. It says it is connecting and keeps waiting for a server connection. The Web Tools don't even start. The http://localhost:9443/denodo-restfulws/denodotraining is rejected. I tried to configure the ports in the firewall but it still does not work, is there any additional configuration? Thank you.
20-04-2021 05:21:29 -0400

4 Answers

Hi, When I tried to enable SSL for the embedded Web Container, I was able to configure it successfully. Hence, I would suggest you to verify the steps followed to configure SSL in the Embedded Web Container by referring the [Enabling HTTPS in the Embedded Apache Tomcat]( documentation. Also, after enabling SSL in your embedded Apache Tomcat, the protocol used in the URL would be HTTPS and not HTTP. So, you would need to use the below URL to access the Denodo RESTful WS, [https://localhost:9443/denodo-restfulws/denodo_training](https://localhost:9443/denodo-restfulws/denodo_training) Hope this helps!!
Denodo Team
22-04-2021 08:11:21 -0400
Hello, Thank you for your answer I followed all the steps, but the webtools don't start and I can't acess the https://localhost:9443/denodo-restfulws/denodotraining, giving me a ERRCONNECTION_REFUSED. I can't figured it out.
23-04-2021 14:28:49 -0400
Hello, I configured the keystore and truststore and everything went well, but now, when I try to login I get this error: 27550 [DNI(8)] ERROR 2021-04-24T10:58:44.289 com.denodo.internal.o.a.r.netty.RMIServerHandler [] - EXCEPTION CAUGHT: Received fatal alert: handshake_failure com.denodo.internal.i.n.handler.codec.DecoderException: Received fatal alert: handshake_failure at com.denodo.internal.i.n.handler.codec.ByteToMessageDecoder.callDecode( ~[denodo-asyncrmi.jar:8.0.1] at com.denodo.internal.i.n.handler.codec.ByteToMessageDecoder.channelRead( ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at$HeadContext.channelRead( ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at$ ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at ~[denodo-asyncrmi.jar:8.0.1] at com.denodo.internal.i.n.util.concurrent.SingleThreadEventExecutor$ ~[denodo-asyncrmi.jar:8.0.1] at com.denodo.internal.i.n.util.internal.ThreadExecutorMap$ ~[denodo-asyncrmi.jar:8.0.1] at [denodo-asyncrmi.jar:8.0.1] at [?:?] Caused by: Received fatal alert: handshake_failure at ~[?:?] at ~[?:?] at ~[?:?] at$AlertConsumer.consume( ~[?:?] at ~[?:?] at ~[?:?] at ~[?:?] at ~[?:?] at ~[?:?] at ~[?:?] at ~[?:?] at com.denodo.internal.i.n.handler.ssl.SslHandler$SslEngineType$3.unwrap( ~[denodo-asyncrmi.jar:8.0.1] at com.denodo.internal.i.n.handler.ssl.SslHandler.unwrap( ~[denodo-asyncrmi.jar:8.0.1] at com.denodo.internal.i.n.handler.ssl.SslHandler.decodeJdkCompatible( ~[denodo-asyncrmi.jar:8.0.1] at com.denodo.internal.i.n.handler.ssl.SslHandler.decode( ~[denodo-asyncrmi.jar:8.0.1] at com.denodo.internal.i.n.handler.codec.ByteToMessageDecoder.decodeRemovalReentryProtection( ~[denodo-asyncrmi.jar:8.0.1] at com.denodo.internal.i.n.handler.codec.ByteToMessageDecoder.callDecode( ~[denodo-asyncrmi.jar:8.0.1] ... 17 more 29958 [Thread-2] INFO 2021-04-24T10:58:46.697 com.denodo.tomcat.manager.TomcatManager [] - Maximum number of retries reached. Tomcat remains stopped. Thank you
24-04-2021 06:01:05 -0400
Hello and thank you for your reply. After a clean install I was able to use the TLS configurator and it worked fine.
03-05-2021 13:29:11 -0400
You must sign in to add an answer. If you do not have an account, you can register here