You can translate the question and the replies:

how can we escape special characters in the base view from query window?

how can we escape special characters in the base view from query window? When writing cypher quotes and braces are needed.
user
28-06-2018 19:29:00 -0400
code

1 Answer

Hi, I would use the backslash (\\) to escape only braces on the ‘Create from Query’ window. I was able to run the test successfully without escaping other special characters (*, ‘’, -, >, :). Additionally, I would ensure to set the option ‘Delegate SQL Sentence as Sub Query’ to ‘No’ in the Wrapper Source Configuration of the Base View, in order to execute Neo4j cypher statements. You can refer to the related Q&A [How to Create Base View in Denodo to a NEO4J data-source](https://community.denodo.com/answers/question/details?questionId=9060g00000009m7AAA&title=How+to+Create+Base+View+in+Denodo+to+a+NEO4J+data-source%3F) to get more details. Hope this helps!
Denodo Team
29-06-2018 08:32:58 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here