You can translate the question and the replies:

Dependencies tree not auto populating in the "Revision Elements"

Hello, I am creating a revision using the view which has dependencies in different databases. Basically the view which I am trying to promote or Deploy from one enviromnent to another is derieved from a view in different database in denodo. While I select that I am expected to get the dependencies which are associated with the view in the "Dependencies tree" or "Related elements" but I am not getting those views. And when tried to deploy it anyway the deployment is giving an error that the dependent view cannot be found in the environment to be deployed. Let me know if there is any way to activate the elemnets to be autopopulated in the "Dependencies tree" or "Related elements" section. Thanks & Regards, Gokul

3 Answers

Hi, I tried to test this scenario and it works perfectly well for me when both the Solution Manager and the Platform have the same version of update installed, but I was able to reproduce this behavior when using different versions of the update installed. For all functionalities to work seamlessly well between the Solution Manager and the Platform, it is important that you have the same version of updates applied to both of them. You can check the update which is applied in the solution manager and the platform by clicking on the Update tab in the Denodo Solution Manager/Denodo Platform Control Center screen and match them in case they are different. You can refer to this link to know how to install updates: [Installing Updates And Hotfixes]( Hope this helps!
Denodo Team
17-07-2019 11:32:25 -0400
Hello, Thanks for the reply. I can see that both the Solution manager and Platform are having the same version of update installed (Denodo Platform 7.0 Update 20190312) and yet I am finding this issue. Let me know if I am missing something. Thanks, Gokul
18-07-2019 08:01:03 -0400
Hi, One more thing that I can recommend is to check if you are using the correct Virtual DataPort Server Database, by unchecking 'Use the default Virtual DataPort Server database' and keying in the database name that has your views which are to be imported, in the General tab. If you have left it at default (admin database) then the dependencies will not populate in Revision Elements, if your views lie in a database that is different than the default admin database. For understanding different options available for configuring your new revision, you can check [Creating Revisions-general Options]( If this is configured correctly and you are still facing the issue, I would highly recommend that you create a support case so that the team can have a detailed look at your configurations. Hope this helps!
Denodo Team
25-07-2019 04:39:04 -0400
You must sign in to add an answer. If you do not have an account, you can register here