You can translate the question and the replies:

Unrecognized SSL message - SSL Exception while instantiating SchedulerManager Class.

Whenever I try to instantiate the ScehdulerManager class in my Java project using the below code : SchedulerManagerFactory.getManager(context); I get the below Connect Exception : * error during JRMP connection establishment; nested exception is: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection? at com.denodo.scheduler.client.remote.RMISchedulerManager.init(RMISchedulerManager.java:171)* My context object contains hostname, port, login and passowrd parameters, and they seem to be correct. Can you please suggest what is going wrong?
user
10-04-2018 05:08:59 -0400
code

1 Answer

Hi, I think that this issue could be due to a couple of reasons: * You aren't using the correct port number. * You are trying to connect to Scheduler using SSL connection, but Scheduler isn't well configured and is working as a non SSL end-point. So, I think you could do the following checks in order to solve this issue: * Check you're using the correct port number for SSL connections. * Review the configuration for [enabling SSL in your Scheduler server](https://community.denodo.com/docs/html/browse/6.0/platform/installation/postinstallation_tasks/enable_ssl_connections_in_the_denodo_platform_servers/enabling_ssl_in_denodo_platform_servers). * Review that you've [enabled SSL for external clients](https://community.denodo.com/docs/html/browse/6.0/platform/installation/postinstallation_tasks/enable_ssl_connections_in_the_denodo_platform_servers/enabling_ssl_for_external_clients) to secure the communication between Scheduler (or any Denodo server) and the clients. Also, take into account how you should [obtain and install the SSL certificate](https://community.denodo.com/docs/html/browse/6.0/platform/installation/postinstallation_tasks/enable_ssl_connections_in_the_denodo_platform_servers/obtaining_and_installing_an_ssl_certificate). Hope this helps!
Denodo Team
11-04-2018 08:31:43 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here