You can translate the question and the replies:

Cache error by inserting null data

When I make a query to save in cache, at the end I get the following error: "ERROR_LOAD_CACHE", "Error loading cache: There was an error while inserting data: null", in the fields use the function: COALESCE to avoid null values someone would have some idea what happens, thank you
30-04-2018 19:20:38 -0400

2 Answers

Hi, In the past, I had a similar situation when using Bulk Data Load API in Cache configuration. I just downloaded the latest Denodo Express available in the community, tried to make a query to save in cache and it is working for me. So I advise you to download the express and try again. If error still persists, you can use COALESCE function in your query to replace field that could contain null values with any other sample value. For more details on Coalesce and other functions please refer document Hope this helps!
Denodo Team
04-05-2018 03:11:05 -0400
Hi, Thank you very much for the reply, it was solved by updating the version the denodo from 6 to 7.
18-05-2018 11:45:40 -0400
You must sign in to add an answer. If you do not have an account, you can register here