You can translate the question and the replies:

LEAD function doesn't work in Denodo 8

Hi there, when I tried to use LEAD function in Denodo 8, the color doesn't change and the error shows the Function LEAD is not executable. From the documentation, the LEAD function is available in Denodo. What I have missed? Thank you!
user
17-04-2024 17:02:14 -0400
code

1 Answer

Hi, In the event of encountering this error, I would verify whether the [LEAD()](https://community.denodo.com/docs/html/browse/latest/en/vdp/vql/functions/analytic_functions/analytic_functions#lead) function is listed among the analytical functions. It’s important to note that Virtual DataPort can delegate analytical functions, but it cannot directly execute them. If a query relies on one of these functions and it cannot be delegated to a database, the query will result in failure. I recommend exploring the potential solutions provided in this similar community question available [here](https://community.denodo.com/answers/question/details?questionId=9064u000000CfQrAAK&title=Analytic+Functions+%28Window+Functions%29+using+denodo+8.0++Error+executing+view%3A+Function+row_number+is+not+executable++Any+possible+ways+to+use+Analytic+Functions+in+denodo). For more information on the types of analytic functions supported by Virtual DataPort, please refer to the [Analytic Functions](https://community.denodo.com/docs/html/browse/latest/en/vdp/vql/functions/analytic_functions/analytic_functions) guide. Hope this helps!
Denodo Team
19-04-2024 12:57:18 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here