You can translate the question and the replies:

Services fail to start, referring to wrapper.startup.timeout

The Denodo 8 services failed to start on a Windows 2019 machine (startup type = Automatic). When looking at the logs, I found the following message: ```text WARNING|7680/0|22-06-01 12:10:45|startup of java application timed out. if this is due to server overload consider increasing wrapper.startup.timeout ``` This is likely due to all services trying to start simultenously at server boot time, thereby exceeding the aforementioned timeout. However, I found nothing in the documentation as to where this parameter (*wrapper.startup.timeout*) has to be changed, nor what the default value is. I only found mentions of ** and ** in the KB article [VDP as Windows service with large memory heap configurations]( Are the files to be modified for the startup parameter the same? What is the default value and what would be a suggested value in case of failures?
01-06-2022 07:55:09 -0400

1 Answer

Hi, The property **wrapper.startup.timeout** denotes the time within which VDP service needs to complete its startup process. If startup is not finished by this time interval, it stops automatically. The property has a default value of 30 seconds. If needed to modify this default value, then **wrapper.startup.timeout** has to be added in **<DENODO_HOME>/conf/vdp/service.conf** file explicitly as it is not available in this conf file out of box. I cannot recommend any value as this depends on the specific server and how long it takes to start all the other services. I would usually follow a trial and error method, and set the value high enough to get the VDP service started, and then increase/decrease it accordingly. It’ll also be better to leave some buffer time in case the delay in starting up increases in future. Hope this helps.
Denodo Team
07-06-2022 05:34:12 -0400
You must sign in to add an answer. If you do not have an account, you can register here