You can translate the question and the replies:

While executing a base view pointed to Postgre SQL from denodo, transaction is opened in Postgre SQL even we use Source configuration as SUPPORTEDDISTRIBUTEDTRANSACTIONS as false in the view defination

We have created a base view pointing to Greenplum and when we try to execute and verify query in Greenplum, we are seeing begin & commit transactions even for reading the data. We modified the view to use SUPPORTEDDISTRIBUTEDTRANSACTIONS property as false. Even then we are seeing the same. Greenplum version -5.4 Denodo -6.0 Please let us know how we can stop sending begin and commit transactions to greenplum from denodo.
03-05-2018 07:26:08 -0400

2 Answers

Hi, I would add an optional URL parameter to the JDBC connections: **autoCommit=true**. When this property is found, the JDBC API methods to manage transactions that don't have effects on the server (setAutoCommit, commit, rollback). For more details, you can refer to the [Parameters of the JDBC driver and their default value]( of Virtual Dataport Administration guide. Hope this helps!
Denodo Team
07-05-2018 05:01:27 -0400
Hi, I tried keeping passing JDBC connections url as DATABASEURI = 'jdbc:postgresql://[servername]:5432/[db name]?autoCommit=true' and we are still seeing the Begin & Commit in the sql queries that are hitting greenplum database. Do I need to make any other changes. Please suggest. Thanks in advance!!!
08-05-2018 08:09:10 -0400
You must sign in to add an answer. If you do not have an account, you can register here