You can translate the question and the replies:

Postgres ODBC driver version for accessing Denodo 7.0

Is client access to Denodo 7.0 supported using Postgres ODBC driver versions later than 09.05? (We know that using the Denodo supplied ODBC driver is best, but some of our client apps use the Postgres driver)
user
19-05-2022 09:41:15 -0400
code

1 Answer

Hi, In general, currently it is recommended to use the [native ODBC Driver](https://community.denodo.com/docs/html/browse/7.0/vdp/developer/access_through_odbc/access_through_odbc) which is based on **PostgreSQL driver version 09.05** because it has necessary functions and mapping for accessing the Denodo Platform. This can be found under the directory **<Denodo_Home>/tools/client-drivers/odbc**. Even though the Virtual DataPort server connects using the ODBC driver, I suggest you use the **JDBC driver** over the ODBC because the performance is better. I would like to let you know that as per the [Supported JDBC Data Sources](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/appendix/supported_jdbc_data_sources/supported_jdbc_data_sources#supported-jdbc-data-sources) section of the Virtual DataPort Administration Guide, Denodo Platform officially supports the JDBC drivers for Postgres 8, 9, and 10 (includes all minor versions). In order to establish connection to this version, you could use the inbuilt driver version distributed by Denodo Platform **postgresql-42.2.5.jar** which is available under **<Denodo_Home>/lib/extensions/jdbc-drivers/postgresql-x**. Hope this helps!
Denodo Team
20-05-2022 05:56:38 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here