You can translate the question and the replies:

Scheduler jobs authentication errors with kerberos

When users create new Scheduled jobs they fail with authentication errors.: 3020866130 [CacheView_10 (default).DenodoSched_Worker-4] ERROR 2019-07-24T16:23:25.779 com.denodo.scheduler.core.dataSource.DataSourceLocator [[CacheView_10 (default).DenodoSched_Worker-4]] - com.denodo.scheduler.core.dataSource.connection.ServerConnectionException: authentication error: The username or password is incorrect 3020866130 [CacheView_10 (default).DenodoSched_Worker-4] ERROR 2019-07-24T16:23:25.779 com.denodo.scheduler.core.job.BaseJob [[CacheView_10 (default).DenodoSched_Worker-4]] - Initialization Error. dataSource 'wam_dv'. authentication error: The username or password is incorrect The user who created teh job has access to those tables, do we need to add a schedular user to the role?. We only have one other job defined VDPIndexer and it runs fine, so we may just be missing a setup piece. Thanks John
24-07-2019 20:06:04 -0400

1 Answer

Hi, I came across the same error in Denodo scheduler when the username or password is incorrect in the VDP Data source. Make sure that you have entered the correct user and password in VDP Data sources. To create a job using VDP Data source by Kerberos authentication ensure that you have enabled the ‘use Kerberos‘ option in VDP Data Sources because by default it will be disabled and also, ensure that Kerberos authentication is properly configured in the server configuration. For more information, you can refer to the following sections [Kerberos Setting]( and [VDP Data Sources]( of the Scheduler Administration Guide. Also, you can refer to the Knowledge Base article [Kerberos configuration and troubleshooting]( for troubleshooting errors related to Kerberos. Hope this helps!
Denodo Team
30-07-2019 01:54:48 -0400
You must sign in to add an answer. If you do not have an account, you can register here