You can translate the question and the replies:

Partial cached data subset still going to source

We are currently trying to use partial cache in denodo in both the versions of 6 & 7 and facing one issue. When we put the partial cache on for the view and run the query to cache it. For eg. Select * from test1 where id in (1,2,3,4); it caches this whole set but when we query it after as this Select * from test1 where id in (1,2); It is still going to the source and not able to identify that the result is in cached dataset. When we run this we get it from cache : Select * from test1 where id in (1,2,3,4); Is that a normal behaviour? Its the same with explicit loads option checked or without it. Please help. Thanks.
10-05-2019 20:01:26 -0400

1 Answer

Hi, This enhancement request is already submitted for future considerations. However, I tried another scenario with partial caching and it worked for me. I did the following steps: Run the VQL, ‘Create view test as select 1,2,3 from dual() Turn on partial cache. Run the query, ‘SELECT * FROM test WHERE field1 = 1’. The data set is cached now. Run the query, SELECT * FROM test WHERE field1 = 1 and field2 = 2’ and it comes from the cache. Usually I prefer using the full cache mode over partial cache because of certain limitations of partial cache. So, you might want to reconsider using full cache mode for your scenario or using the ‘and’ operator as shown above. For more information, you can go through some [best practices for caching]( Hope this helps!
Denodo Team
14-05-2019 18:48:27 -0400
You must sign in to add an answer. If you do not have an account, you can register here