You can translate the question and the replies:

Cache modes

Hi, I'm using the Denodo Express Edition platform and I'm trying to try the partial cache mode with the Match exact queries only option. I have entered Administration> Server configuration and I have activated Cache Status. Then before executing the query, I activated the partial cache mode and selected the Match exact queries only option. I run the same query twice and it does not use the cache, it runs from the sources again. Does anyone know if I have forgotten something to do? I followed the tutorial and it does not work. Thanks.
28-12-2018 05:10:58 -0500

1 Answer

Hi, I have tried to reproduce your results, and it works for me. The issue could be a result of the “Explicit Loads” option being selected. If that option is selected, you must load the cache manually using the Context clause with these parameters: ‘cache_preload’ = ‘true’ ‘cache_wait_for_load’=’true’ It will look something like this: “Select * from derived_view_name where condition CONTEXT(‘cache_preload’ = ‘true’, ‘cache_wait_for_load’=’true’) If you want the cache to be automatically loaded when using the partial cache mode, please ensure that the “Explicit Loads” option is not selected. To know more about the partial mode of cache read the section “Partial Mode“ and “Recommended Parameters for Queries that Load the Cache” of the Virtual DataPort Administration Guide. Hope this helps.
Denodo Team
07-01-2019 17:56:38 -0500
You must sign in to add an answer. If you do not have an account, you can register here