You can translate the question and the replies:

Denodo SSO SAML with Azure AD failed "Error validating SAML message" & "insufficient privileges to connect to the database 'admin'"

I tried setting up Azure SAML SSO in denodo express edition, It gives me below errors. I tried assigning different roles (allusers, admin, User, global_admin) to users but nothing is working. Open ID SSO Configuration is working good. Error validating SAML message insufficient privileges to connect to the database 'admin' SSO Configurations: Authentication method : SAML SAML entity ID : http://localhost:19090/solution-manager-web-tool/saml SAML signing request : YES Identity provider metadata URL :<tenant_id>/federationmetadata/2007-06/federationmetadata.xml?appid=<client_id>
22-03-2021 04:30:24 -0400

2 Answers

Hi, In this case, I will take the following to analyze the problem: Since the error message indicates that the authenticated user does not have the privilege to connect to "Admin" database, so I will check the privilege for that user. I found the relevant info in the following manual. * [User and Access Right in Virtual DataPort]( Hope this helps!
Denodo Team
23-03-2021 05:50:50 -0400
Hello I have simillar issue, without SSO login the global_admin roles itself proved out to be correct, but when being tried with SSO it is giving me message as stated above. Why this is giving me such message when i am only trying to access solman webtool. I would agree if it comes out to be accesing VDB through Studio. Thanks
25-01-2023 01:03:33 -0500
You must sign in to add an answer. If you do not have an account, you can register here