You can translate the question and the replies:

Change VDP port

Our server is running VDP on a different port 1111 than using 9999. To connect the VDP client from my local machine I have changed the URI: to point to 1111 and changed VDP port mentioned in to 1111. It's still not connecting. When server changes port to 9999 again for me to test it and I undo these changes then the connection is working. Is there anywhere else we need to change port to 1111? The port 1111 is open on my machine and network firewall.
20-02-2018 11:24:56 -0500

2 Answers

Hi, The first thing I would check is to make sure the server administrator (or whomever is changing the port settings on the server) is actually restarting Virtual DataPort Server after changing the configuration. If they do not, then even if the *Server configuration* screen is showing 1111, the server is still *running* on 9999 until it is restarted. You can attempt a connection on 9999 to validate this. Assuming that's correct, you can take a look at the *DENODO_HOME/logs/vdp-admin/vdp-admin.log* on your workstation to get some detail on the error shown when you attempt to log in using port 1111. If necessary, take a look at the documentation on changing the level of detail captured by the [Logging Engine]( You shouldn't need to change the port anywhere else. In fact, the file *vdbDataSource.vdpAdminDataSource.vdbURI* property only controls the default you see when you launch AdminTool - this gets updated automatically based on what you set in the UI and shouldn't need to be changed manually. Hope this helps!
Denodo Team
20-02-2018 14:08:10 -0500
Thanks but I am still having to connect VDP client to the server on the new port. I am able to connect Denodo VDP database using DB visualiszer but updating the port from 9999 to 1111 but the VDP client is still not connecting from what I think it's the AUX port (default value 9997) that might be causing the issue. On the server the AUX port is 1113 but on VDP client I don't any option to change the AUX port from 9997 to 1111 except the one we have under VDP client -> configure option which doesn't seems to be working as I tired changing the AUX port there.
22-02-2018 05:18:30 -0500
You must sign in to add an answer. If you do not have an account, you can register here