You can translate the question and the replies:

Linux: ODBC Driver: Query result on a column got truncated

ODBC Driver Version: denodo-vdp-odbcdriver-8.0-update-20230914-linux Linux: Ubuntu 22.04.2 LTS On Windows, below query returns data without any truncation. (Note it contains Japanese character in the result) SQL Query: select "col1" from "test"."tableA" Result: abc2_<some_japanese_characters>_A, abc2_<some_japanese_characters> _B, ... However, when you run the exact same query on Linux, the result is truncated and it shows only first 10 characters like "abc2_<truncated_japanese_characters> " I expliclity set UnknownSizes=0;MaxVarcharSize=255;MaxLongVarcharSize=8190, but this does not help. Since this does not show non-ascii characters proplerly, I put screenshot of the Japanese characters I used for my testing.
08-04-2024 12:22:09 -0400

1 Answer

Hi, I believe the simple fact that the first 10 characters display properly for Linux is enough to suggest that the Japanese characters are not posing any issues. This is likely a problem involving field length and there are a number of places that a configuration could be truncating the results one of which being the [maximum length of text values]( settings for the [DSN](, i.e. `Unknown sizes = Maximum` and `Max Varchar`. I would examine the [Execution Trace]( or the query plan via [DESC QUERYPLAN]( for the query in question and take note of each of the points where the data is handed off from one node to another. Then I would inspect the configurations involved in each of those handoff points. If you are a customer with a valid support account, you could escalate this to be a problem ticket on the support site if the answer to the problem isn't readily apparent. That way the issue could be investigated in greater detail. Hope this helps!
Denodo Team
09-04-2024 18:34:42 -0400
You must sign in to add an answer. If you do not have an account, you can register here