You can translate the question and the replies:

Delimited file source headers have _0 appended to them

Sorry, I tried to find an answer by searching but couldn't. I have a .csv data source where every column is enclosed in double quotes. When I create a base view off of this source the quotes are removed, which is great, but the header gets a "\_0" appended to it. This is only an issue with this particular source and I assume it's related to the double quotes because other .csv sources present the header normally and they lack the double quotes. Is there a way to prevent this from happening?

3 Answers

Hi, This happened as the database’s character set is set as *Restricted* mode. I followed the [Identifiers Charset]( documentation guide to switch from *Restricted* to *Unicode* mode and the problem was solved for me. Hope this helps!
Denodo Team
17-10-2021 22:38:15 -0400
Hello, Thank you for preenting this workaround. Unfortunately, changing the character set is not an option here as it would disrupt too many other things in order to fix the one. I guess I don't even understand why the header would be changed like this, but data not. Given that data rows are properly stripped of double quotes and headers are obviously identified and defined as headers because they are stripped of double quotes and then appended with the "\_0", I have raised an enhancement request for this. Thanks again.
18-10-2021 09:16:58 -0400
Hi, Great to know that an enhancement request has been raised. Since a request is raised, Denodo Support team should be able to help you on this. Hope this helps!
Denodo Team
26-10-2021 00:59:30 -0400
You must sign in to add an answer. If you do not have an account, you can register here