You can translate the question and the replies:

How to pass comma delimited value to webservice

My view query looks like Select val1, val2, val3 from iv_view where val1 in (input_Val). I am passing input_Val from query string in web service call. If I pass a single value I get a single result but if I pass multple values I don't get any results. My web service call looks like. http://localhost:9090/denodo-restfulws/support/views/customer?ID=10715416 - does work http://localhost:9090/denodo-restfulws/support/views/customer?ID=10715416,11627122 - Doesnt' work What can I do to get the multi-value call to work?
user
20-04-2022 12:34:59 -0400
code

1 Answer

Hi, In order to pass comma-separated values as filter conditions to the URL of the Web Service, I would use the **$filter** parameter along with **IN** operator in the following format : `http://<hostname>:<port_number>/server/<databasename>/<web servicename>/views/<viewname>?$filter=<field_name> IN (<conditions>)` Here, field_name refers to the column on which the filter is to be applied. You can have a look at [Input Parameters of the RESTful Web Service](https://community.denodo.com/docs/html/browse/latest/en/vdp/administration/restful_architecture/restful_web_service/input_parameters_of_the_restful_web_service) section of the Virtual DataPort Administration Guide for more information. Additionally, if you still need help and if you are a user with valid support access then you can create a support case in [Denodo Support Site](https://support.denodo.com/) so that the support team will assist you further. Hope this helps!
Denodo Team
21-04-2022 07:47:38 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here