You can translate the question and the replies:

The following fields are obligatory in the view 'view_name' : field_name

Hi Denodo Team, When I am trying to run a select query from java (through jdbc connectivity) on one of my view in denodo, I am having an issue in getting result. It is throwing the error : ** SQL state [HY000]; error code [31002]; No search methods ready to be run. The following fields are obligatory in the view 'my_view_name': some_column_name; nested exception is java.sql.SQLException: No search methods ready to be run.** But when I try to run the same query directly in my virtual dataport in denodo it is fetching the result. The view was created from an SAP datasource in denodo. Your help is highly appreciated. Thanks in Advance. Kranthi Kiran.
03-06-2021 05:58:12 -0400

1 Answer

Hi, The Virtual DataPort uses “Search Methods” to describe the way that its Base Relations can be queried. The error, “No search methods ready to be run”, results from the query missing a value that it relies on to execute, for example, Mandatory Fields that are used to filter in the Where Clause. I would confirm which fields of my View are “Mandatory”, by opening the Virtual DataPort Administration Tool, clicking on the [View Name] > Options > Search Methods, and seeing which fields are listed as “Mandatory Fields :”. If I am able to make the query through the Virtual Dataport UI, but it fails programmatically, this is most likely because my program is sending a request that does not include all the required fields, while the UI has some default value set for them. I can find any Default Parameters on my View by opening the Base view in the Virtual DataPort Administration Tool, and clicking Edit > Model > and then the Edit icon next to “View Parameters”, which will open a list of the parameters, alongside any default value they may have. You can find more information about the VDP Search Methods in the [Search Methods and Wrappers]( Section of the Virtual DataPort VQL Guide. Hope This Helps!
Denodo Team
07-06-2021 16:41:46 -0400
You must sign in to add an answer. If you do not have an account, you can register here