You can translate the question and the replies:

Caching issue while sending data to MYSQL workbench.

Hello, I have a problem with caching the data I got an error : Finished with error: Error loading cache: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Loading local data is disabled; this must be enabled on both the client and server sides. Tried searching on internet and changed the setting in the ini file of MYSQL 8.0 folder :(my.ini file) local_infile=1 Still the problem persists, can you let me know on how to solve this problem of caching. I am trying out partial caching.
user
16-10-2020 02:17:32 -0400
code

1 Answer

Hi, This error is being thrown from the MySQL jdbc driver when the MySQL server does not allow "Loading local data". This feature needs to be enabled in the server first. The documentation section for [MySQL](https://community.denodo.com/docs/html/browse/8.0/vdp/administration/bulk_data_load/mysql) about Bulk Data Load from the Virtual DataPort Administration Tool explains how to enable this for MySQL 8.0. If that still does not solve your problem, I would try to check with the MySQL administrator on the configuration and consult as well the documentation of MySQL that explains in more detail on this feature: [6.1.6 Security Considerations for LOAD DATA LOCAL](https://dev.mysql.com/doc/refman/8.0/en/load-data-local-security.html) Another idea is to try loading data into MySQL from another third party client to see if you are able to do it from there. If it fails from there as well it indicates a misconfiguration in the MySQL server. Hope this helps!
Denodo Team
16-10-2020 07:03:15 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here