You can translate the question and the replies:

The Solution Manager Server has not been started correctly

I got below errors when i try to login solution manager. ``` The Solution Manager Server has not been started correctly ``` Then i checked solution-manager.log, it seems vdp server not started well. but im using 「solution-manager-8.0-20210715」image and set args like this. As i know, it is unnecesary to run vdp component in solution manager container. > hostname: denodo-solutionmanager > containers: > - name: denodo-solutionmanager > image: denodo-sm:20210715 > command: ["./denodo-container-start.sh"] > args: ["--lmserver", "--smserver", "--smadmin"] ``` root@denodo-solutionmanager:/opt/denodo# cat logs/solution-manager/solution-manager.log 1467 [main] INFO 2021-08-03T01:20:59.259 server.start [] - Starting Denodo Solution Manager Server 8.0 20210715 - Operating system: Linux (amd64) - OpenJDK Runtime Environment (build 11.0.8+10) - OpenJDK 64-Bit Server VM (build 11.0.8+10, mixed mode) 61873 [ThreadPoolTaskExecutor-1] ERROR 2021-08-03T01:21:59.665 com.denodo.solutionmanager.service.VdpLauncherManager [] - Vdp server not started 112313 [http-nio-10090-exec-4] ERROR 2021-08-03T01:22:50.105 com.denodo.solutionmanager.service.AuthenticatorService [] - com.denodo.vdb.vdbinterface.common.clientResult.VQLException: Connection error: Check the host name and port number are correct, and that client and server belong to the same Denodo major version. Connection refused: localhost/127.0.0.1:19999 112315 [http-nio-10090-exec-4] ERROR 2021-08-03T01:22:50.107 com.denodo.solutionmanager.rest.controller.util.BaseErrorController [] - Authentication exception: Connection error: Check the host name and port number are correct, and that client and server belong to the same Denodo major version. Connection refused: localhost/127.0.0.1:19999 com.denodo.commons.exceptions.AuthenticationException: Connection error: Check the host name and port number are correct, and that client and server belong to the same Denodo major version. Connection refused: localhost/127.0.0.1:19999 at com.denodo.solutionmanager.service.AuthenticatorService.vdpLogin(Unknown Source) ~[solution-manager-lib.jar:8.0.2] at com.denodo.solutionmanager.service.AuthenticatorService.vdpLogin(Unknown Source) ~[solution-manager-lib.jar:8.0.2] ```
user
02-08-2021 21:44:19 -0400
code

6 Answers

BTW, solution manger runs well then i using docker. Only license was mounted. No other extra settings configured. It should be work easily. below is my manifest. ``` apiVersion: apps/v1 kind: Deployment metadata: name: solution-manager-deployment namespace: denodo spec: selector: matchLabels: app: solution-manager-app replicas: 1 template: metadata: labels: app: solution-manager-app spec: hostname: denodo-solutionmanager containers: - name: denodo-solutionmanager image: denodo-sm:20210715 command: ["./denodo-container-start.sh"] args: ["--lmserver", "--smserver", "--smadmin"] ports: - name: license-manager containerPort: 10091 - name: web-http containerPort: 19090 volumeMounts: - name: license-volume mountPath: /opt/denodo/conf/denodo.lic subPath: denodo.lic imagePullSecrets: - name: denodo-pull volumes: - name: license-volume configMap: name: sol-license ```
user
02-08-2021 21:55:55 -0400
Self-Solve. Java process didnt start well caused by a lack of default pod resource. Issue sloved by setting resource in manifest. ``` resources: limits: memory: "16Gi" cpu: "4" ```
user
03-08-2021 20:05:10 -0400
Sorry. it just works one time. resource is not causes.
user
03-08-2021 22:23:10 -0400
The causes is vdp server not started well. so i add this arg parameter in manifest and tested it several times. It is runs well. ``` args: ["--lmserver", "--smserver", "--smadmin","--vqlserver"] ``` Im not sure whether it is also occur on the other user who use k8s. the sample manual didn't writte vql parameter. https://community.denodo.com/kb/en/view/document/Deploying the Denodo Solution Manager in Kubernetes?category=Operation
user
03-08-2021 22:42:39 -0400
im not sure if it is correct to add vqlserver parameter when deploy solution manager. i will be appriciate if denodo support could reply this issue.
user
03-08-2021 22:44:24 -0400
Hi, I am glad that you found a workaround for this problem. You can include an argument --vdpserver in your command to get around this issue and the implementation of an error will be introduced in future updates which will prevent this scenario. Please find below the list of Denodo modules that require VDP server, 1) Data Catalog/ Information Self-Service Tool 2) Denodo SSO 3) Diagnostic and Monitoring Tool 4) Aracne Administration Tool 5) License Manager 6) Solution Manager server 7) Solution Manager Administration Tool 8) Web Panel All these components require Virtual DataPort server for their successful run. Hope this helps!
Denodo Team
04-08-2021 17:56:38 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here