You can translate the question and the replies:

Git local account locked

While exploring the VCS Management using Git, I tried to upload a "Global elements" jar file for a data source to git, which was too large. I actually attempted to load 2 by checking the 2 jars under "Global elements" menu of VCS under the datasource. One file loaded successfully, the other failed due to size. Now the local git repository on my VDP (Design Studio) is locked (red icons) and will not allow further VCS activity. I need to get to the command line git repo to get this unlocked, but I'm not successful in finding where it lives on the server. I've tried a PULL and COMMIT on the virtual database, but keep getting "Missing Commit", likely for the large jar file that did not copy to the remote Git repo. Where does this local repo live?
25-01-2024 15:43:25 -0500

1 Answer

Hi, In general, the Local repository home is a directory where the server creates the local repositories for databases which have VCS enabled on them. If I want to locate the path of the Local repository directory, then by default the path will be **‘<DENODO_HOME>\work\vdp\repository’**. In case, if you have configured a different path, you could navigate to that path which would have the configured Git repositories. For further information, please refer to [Virtual DataPort Server Configuration]( document under the Virtual DataPort Administration Guide section. If you still need further assistance and if you are a valid support user, you can raise a [Support Case](, for further assistance from the Support Team. Hope this helps!
Denodo Team
29-01-2024 23:14:29 -0500
You must sign in to add an answer. If you do not have an account, you can register here