You can translate the question and the replies:

Web access shows "The page you requested was not found."

After trying for several days to install your software on an headless machine on azure where the application refuse to listen to the public ports I've left azure and moved to google cloud. I've downloaded your tar.gz, unpacked it and ran ` install` which went OK After that I've edited the `/etc/hosts` and added a new hostname called `denodovm` with the private machine's IP and last I've edited `/opt/denodo/conf/vdb/` where I've edited `com.denodo.vdb.vdbinterface.server.VDBManagerImpl.registryURL=denodovm` I've installed successfully the application and all the ports are available on the public network as can be seen : ``` [yaniv@instance-2 ~]$ ss -tuna | grep LISTE tcp LISTEN 0 128 *:22 *:* tcp LISTEN 0 100 *:* tcp LISTEN 0 50 :::9098 :::* tcp LISTEN 0 1 ::ffff: :::* tcp LISTEN 0 50 :::9996 :::* tcp LISTEN 0 50 :::9997 :::* tcp LISTEN 0 50 :::9998 :::* tcp LISTEN 0 50 :::9999 :::* tcp LISTEN 0 50 :::37877 :::* tcp LISTEN 0 128 :::22 :::* tcp LISTEN 0 100 ::1:25 :::* tcp LISTEN 0 100 :::9090 :::* tcp LISTEN 0 50 :::9097 :::* ``` On my desktop, I've installed denodo with GUI and added a new hostname under `/etc/hosts` with `denodovm` and the PUBLIC IP. I've tried to access the remote server with the desktop VDP tool on the new installed server (username and password both are admin @ port 9999) but that didn't worked (timedout after a few minutes). Trying to access the web ui (http://publicIP:9090) does lead me to a page that show denodo logo and the message: ```The page you requested was not found. The page may no longer exist, or you may have typed the URL incorrectly.```
19-03-2017 08:24:28 -0400

1 Answer

The steps you described are correct, but I think they miss the regeneration of the startup files (and a restart of the Denodo Server afterwards). Please follow the instructions described in our KB article [Installation Steps on a cloud environment](, esp. step #4 on the server side. This step is necessary that the changed RMI host configuration is applied. The response of the web server listening on port 9090 is correct - there is no content to be delivered, but the server responds (by intention) with this message. Please let us know if that works for you.
Denodo Team
24-03-2017 08:31:04 -0400
You must sign in to add an answer. If you do not have an account, you can register here