You can translate the question and the replies:

SSO Authentication (SAML) - works only on incognito browser window

Hi Team, I am enabling SSO Authentication in Solution Manager, once configuration is done and respective roles created, when I try to login to SM using Web URL in direct browser window it is errors out "Error validating SAML message", but when I try in browser incognito mode it works properly. Please do we have any solution for this.
09-06-2023 06:14:34 -0400

1 Answer

Greetings , Hope you are doing well. The "Error validating SAML message" is common when there are issues with SAML configuration in Denodo. In this case, this error typically means the Solution Manager is improperly validating the received SAML message. However, since such error is observed in regular browser window, here are some possible reasons and checks to be performed: 1. The issue might be related to the cookies and cache stored in the browser since such settings might affect the SAML authentication and validation process. Try clearing the browser cookies and re-login to the Solution Manager admin tool. 2. Verify if you are using Denodo [supported browsers]( 3. Login to the Solution manager admin tool using regular browser window while disabling any active browser extension. 4. Alternatively, I would check the Solution Manager logs located in `<SOLUTION_MANAGER_HOME>/logs/solution-manager-web-tool` while performing above mentioned behavior to check for relevant errors. If the issue persists and you have a valid support account, create a case in [Support Site]( to further assist in resolving this issue. Hope this helps !
Denodo Team
12-06-2023 05:37:15 -0400
You must sign in to add an answer. If you do not have an account, you can register here