You can translate the question and the replies:

How do I import/export a single scheduler job?

I created a scheduler job that has a large number of mappings for a JDBC insert on my test environment. As you can imagine, I don't want to re-type it all in production. I used the export.bat script under $DENODO_HOME/Tools/Scheduler and made the changes to the XML file to point to the new datasource. I tried importing it in Production, but it tells me the project already exists (Denodo 5.0). Is there a way to import just a single job? Am I missing something simple?
19-03-2015 14:13:41 -0400

3 Answers

Hi, When you use the import tools, both in a graphical way or using the scripts, you can replace the jobs with the following options: - "Replace Jobs if exist": using the graphical way. - "-replaceJobs" using the script (Section "USE OF THE IMPORT/EXPORT SCRIPTS FOR BACKUP" of the Scheduler Administration Guide). The process will import the information but only replacing the selected elements (Jobs, data sources, filters...) . If you only need to import a specific job of a project, you can delete other jobs from the generated zip file. The message "Project 'xxx' already exists" is just a warning. If you replace an element the message displayed will be something like this: "Job 'xxx' already exists and has been replaced". Hope this helps!!
Denodo Team
19-03-2015 19:53:55 -0400
After I exported, the project name in test was called "default" but in production it's called "Production". So I manually recreated the zip and accidentally named the internal folder "jobs" instead of "job". After renaming it, it cleared the warning. Now it says that the Import was successful, but my job doesn't show up. I tried both in the GUI and command line, and both say successful. Only thing the log says is that it can't delete the temporary file, but it doesn't have any other errors. I bounced the scheduler service and it still doesn't show up. Any idea why it doesn't show up? I checked and made sure all the referenced data sources exist.
20-03-2015 09:15:55 -0400
Ok well obviously I'm losing it this morning :) I had an extra "data" folder in the zip so it couldn't navigate the structure properly. Now that I actually did it correctly I think I'm all set. Thanks!!
20-03-2015 09:23:55 -0400
You must sign in to add an answer. If you do not have an account, you can register here