You can translate the question and the replies:

using Graph-QL client found - Introspection request failed: 500

I prepared all and tested GraphQL with PowerShell and is working fine, but. I am using a Graph-QL client (Altair), as some samples provided in the Denodo documentation, provided the following POST url "http://localhost:9090/denodo-graphql-service/graphql/edam_db" and header as "Authorization: Basic <my-base-64-password-token>", and always get "Introspection request failed: 500". In the browser, if I type "http://localhost:9090/denodo-graphql-service/graphql/edam_db" I get the schema as expected. None of the forumns in the internet have an answer that works, can you help? Hope to hear from you guys soon... Ed.
user
05-04-2024 14:30:15 -0400
code

1 Answer

Hi, Depending on what type of authentication you are using each methods will have their respective format. For HTTP **Basic** the Denodo user name and password are passed as unencrypted base64 encoded text with an Authorization HTTP request header. `<username>:<password> -> Authorization: Basic YWRtaW46YWRtaW4=` For **OAuth2**, you first need to enable OAuth authentication on the Denodo server. Following that, you must obtain an **access token**. This can be achieved using the OAuth 2.0 credentials wizard in the VDP Admin Tool. Once you obtain the access token, pass it to the Denodo GraphQL Service using an Authorization request header: `oauth_token -> Authorization: Bearer oauth_token` Additionally, I would refer to the **Limitations** section of the [Denodo GraphQL Service](https://community.denodo.com/docs/html/document/denodoconnects/7.0/Denodo%20GraphQL%20Service%20-%20User%20Manual#h.gmrgdxp82mfa) manual, for further information on what is supported. Hope this helps!
Denodo Team
08-04-2024 15:15:10 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here