You can translate the question and the replies:

how to prevent changed column names in baseViews from adding "_0"

I have several SQL Server tables where there are column names with spaces. The datasource shows the spaces, but the baseViews column names are created with no spaces and append '_0' to the column names. What configuration or setting can prevent the names from adding the '_0' to the column name? an example is "Phone Type" is renamed to "phonetype_0" Removing the spaces is fine, but the appended characters are causing user complaints. How do you prevent this during baseView creation without altering the view afterwards?
VQL
user
22-09-2023 13:49:04 -0400
code

1 Answer

Hi, In order to avoid this addition of ‘_0’ you can enable ‘Unicode - Case sensitive’ option in the menu "Administration > Server configuration > Identifier charset". More information can be found in the below Knowledge Base article about [Unicode support](https://community.denodo.com/kb/en/view/document/Unicode%20support) . Hope this helps!
Denodo Team
25-09-2023 06:10:02 -0400
code
You must sign in to add an answer. If you do not have an account, you can register here