You can translate the question and the replies:

How to Create Base View and execute in Denodo to a NEO4J data-source?

Hello everyone ... again, I will be quick and objective in explaining my problem. I want to create a Base View from a Neo4j database. I was able to connect the tools with the corresponding driver, placing it in the folder "<INICIO_DENODO> \ lib \ extensions \ jdbc-drivers \ neo4j -3.0 \ <neo4j-jdbc-driver> .jar", placing 'org.neo4j.jdbc.Driver 'as controller class and placing "jdbc: neo4j: bolt: // <HOST>: <PORT>" as URI of the database. Then create a Base View, from a label, using the "Create from Query" option by typing the following: "Match (n: DELIVERED_DIM) return n.id_delivered AS id_delivered, n.description as description" After creating the Base View I put the option "Delegate SQL Sentence as Sub Query" to "No" to ensure the query Cypher will be executed in Neo4j. Then I open a VQL shell window and execute the following query: "SELECT id_delivered, description FROM sop_dv.DELIVERED_DIM" But I get the following error: Finished with error: Error executing query. Total time 0.254 seconds. DELIVERED_DIM [BASE] [ERROR] DELIVERED_DIM [JDBC WRAPPER] [ERROR] Look at the Output option, this error shows me: DELIVERED_DIM [BASE] [ERROR] DELIVERED_DIM [JDBC WRAPPER] [ERROR] DELIVERED_DIM # 0 [JDBC ROUTE] [CONNECTION_ERROR] Unexpected error creating a connection: org.neo4j.driver.v1.exceptions.AuthenticationException: The client is unauthorized due to authentication failure. Received exception with message 'org.neo4j.driver.v1.exceptions.AuthenticationException: The client is unauthorized due to authentication failure.' It shows me an authentication problem, but I put my credentials to create a connection and then from them create my Base Views. We need other credentials besides the user and password of Neo4j, for example what I put is: user: neo4j password: neo4j I do not know what the problem might be, could it be a problem because I use bolt ?, could it be a problem with the Denodo version ?, or with the driver version or the Neo4j? Or simply when you make queries to a Base View has to do with another syntax? I leave the versions of my tools: Neo4j 3.1.1 jdbc Neo4j 3.1.0 denodo platform 6.0 (x86) Note: try a connection using Pentaho Data integration, use the same driver and connect it, make a query in Cypher and execute without any error. Sorry for the bad English :( Please help! kind regards, Enrique Quiroz
14-04-2018 16:20:57 -0400

2 Answers

Hi, The error " Received exception with message ‘org.neo4j.driver.v1.exceptions.AuthenticationException: The client is unauthorized due to authentication failure.’" occurs when the provided Login credentials in the Data source configuration of Virtual DataPort Administration Tool does not match with the underlying Neo4j Data source. To overcome this error perform the following, * Modify the password of Neo4j application by navigating to the "Administration" section of the Neo4j Database, set a new password and restart the Database. * Provide the new password in the Data source configuration of Virtual DataPort Administration Tool. * Now try to execute the query over the Base view. Hope this helps !!
Denodo Team
19-04-2018 05:58:22 -0400
Hi, I tried to change the password of my Neo4j application, but I could only do it using the command ": server change-password". However, it still throws the same error. :(
22-04-2018 03:01:44 -0400
You must sign in to add an answer. If you do not have an account, you can register here