You can translate the question and the replies:

"Remote license not found. The server is not registered in Solution Manager." when starting VDP server in Docker container.

Can't get past the server trying to find a license on the license/solution manager when starting a VDP server in a Docker container. I've successfully started a local installation of a VDP server getting a license from the license/solution manager and I've successfully started a Docker container using an express license. But when I try to start a server in a container with the same as the local one that works then the vdp.log says "Remote license not found. The server is not registered in Solution Manager.". At first I tried starting the Docker container in the default network mode and opening all the required ports but then the vdp.log said it couldn't even find the solution manager even though I could ping the server from the container. But when running the container in network mode host then it seems to be able to find the Solution Manager but not the server registration. I've tried using hostnames "localhost", the hostname of my PC, and the IP of my PC, and reflecting those changes in the RMI registry URL, regenerating files, and starting the server but nothing works. Note the solution manager is hosted on-premises on a VM on the office network and I'm using Cisco AnyConnect VPN to access it. Here are the commands I've used to get this far: Start bash in the container: docker run -it -h <hostname> --network host -v -v --rm --name denodo-vdpserver denodo-platform:7.0-latest bash Regenerate files: ./bin// Start server: ./ --vdpserver Note the last command in the gives the following output: sed: cannot rename /opt/denodo/conf/vdp/sed4L7Nwl: Device or resource busy Starting Denodo VQLServer ... vdp.log: 938 [main] INFO 2021-01-15T14:29:10.743 server.start [] - Starting Denodo Platform 7.0 20201116 - Process owner: root - Operating system: Linux (amd64) - Java(TM) SE Runtime Environment (build 1.8.0_162-b12) - Java HotSpot(TM) 64-Bit Server VM (build 25.162-b12, mixed mode) 981 [main] INFO 2021-01-15T14:29:10.786 server.start [] - TLS is disabled on incoming connections 10103 [main] ERROR 2021-01-15T14:29:19.908 com.denodo.vdb.vdbinterface.server.VDBManagerImpl [] - Remote license not found. The server is not registered in Solution Manager. 10103 [main] ERROR 2021-01-15T14:29:19.908 com.denodo.util.logging.JavaConsoleLogging [] - Unexpected error. Note the local vdp.log also says TLS disabled so don't think that is the issue. Note I of course also tried reflecting the hostnames and IP in the server registration in the Solution Manager.

1 Answer

Hi, I was able to connect to the Solution Manager from VDP server in my Docker environment. I executed docker run command, specifying and In those files, I specified Solution Manager host by its DNS name, not its ip address. I referred to the following Knowledge base document. I believe it should be helpful to you. * [How to create your own Docker images fro Denodo Platform Containers]( If the issue persists and you are a valid support user, you may open a **Support Case** at the [Denodo Support Site]( and Support Team will help you. Hope this helps!
Denodo Team
18-01-2021 06:04:32 -0500
You must sign in to add an answer. If you do not have an account, you can register here