You can translate the question and the replies:

Push down not working in Dendo Version 7

we recently went though an upgrade from Denodo 6 to Denodo 7. We followed the migration guide provided by Denodo. All seemed to have worked. Data was flowing and users logging in. However, some users started placing queries that worked just fine in denodo 6 and they don't work in Denodo 7. Analyzing them, we found they were not pushing down to the source the analytical functions they were using. Rank was the first one we found and it was giving us an error. We also found queries timing out for the same reason, the "SUM", "AVG" and other aggregations were being performed in denodo and it would timeout. So, they were not being pushed down either. We checked our data sources both in 6 and in 7 and they look the same; which means that they migrated as expected. We had not made any changes in the data sources of denodo 6 for the push down to work. They worked pretty much on Default mode; as they were created. So, we did not make any changes in denodo 7 either. So, I find very odd that this feature now does not work and our queries are failing. Any ideas? Any one else has experienced this?
25-06-2019 16:17:34 -0400

2 Answers

Hi, I would verify if the analytical functions used are added to the ‘Delegate analytic functions list’ in ‘Source Configuration’ tab of the data source. You can select the checkbox and add the required analytical functions separated by a comma. Virtual DataPort can delegate these functions to a database, but cannot execute them. You can refer the [Analytic Functions]( section of Virtual DataPort VQL Guide for more information on the analytical functions supported by Virtual DataPort for delegation. If you are a user with support access and still consider that it is a potential problem in Denodo Platform, I would recommend you to raise a support case in the Denodo Support Site( with detailed logs, execution trace or VQL if possible for analysis. Hope this helps!
Denodo Team
26-06-2019 08:04:08 -0400
Thanks for your reply. Yes, that was the first thing I checked. The list of functions is there in the "Delegate analytics functions list." I can tell you though, when I clicked on the flag, the field becomes active and the data source becomes "edited" (meaning that it needs to be saved). I save the change of the data source (anlytics function flag selected for delegation) and, on saving, the field becomes grayed out again and flag unchecked. That seems odd to me. Is that the standard behavior? Yes, we are workig with support. They have not said anything about this follow up question. I am not sure if that is the behavior I should expect; but looks odd.
26-06-2019 08:31:56 -0400
You must sign in to add an answer. If you do not have an account, you can register here