You can translate the question and the replies:

Exporters column mapping

Our source, a base view with the following SQL: SELECT ID*10+2 AS EDIT_ID, ID, Attr1, Attr3 ... Attr130 FROM TABLE_A We want to write some of its columns to two tables, and use the mapping to link certain columns The first exporter is to a table with the following columns: ID Attr1, Attr3 ... Attr130 This gives the error:* "Group0#JDBCExporter0: Invalid column name 'EDIT_ID'."* The second exporter writes to an identical table but with the a parameter mapping to convert the EDIT_ID from the base view to the column ID in the table. This gives the error: *"Group0#JDBCExporter1: The column name 'ID' is specified more than once in the SET clause or column list of an INSERT. A column cannot be assigned more than one value in the same clause. Modify the clause to make sure that a column is updated only once. If this statement updates or inserts columns into a view, column aliasing can conceal the duplication in your code."* Do we have to manually map all the 130 columns and set Export only mapped attributes = true to get this to work? What is the purpose of the "***Export only mapped attributes: false***" option, if Denodo does not map columns by name automatically? Is there a way to roll back all exporters in a job, when one fails?
user
18-04-2018 05:06:15 -0400

1 Answer

Hi, I’d recommend you the following. It appears that your destination table does not have any column called EDIT_ID but this column exists in your source you want to export. Two possible solutions would be to either map EDIT_ID explicitly to a table column or add the EDIT_ID column to the destination table. For the second one the issue is that you are mapping EDIT_ID to ID in your destination table with the option Export only mapped attributes: false. Thus, your ID column also gets exported which raises a conflict, as you already mapped EDIT_ID to the ID field in your destination. I’d thus recommend you either map ID to another table column, to avoid this conflict or, if applicable, you can remove the ID field from the extraction query, if it won’t be used in the destination table. If you apply the steps above you should be able to successfully export using Export only mapped attributes: false. Hope this helps!
Denodo Team
19-04-2018 11:40:07 -0400
You must sign in to add an answer. If you do not have an account, you can register here