You can translate the question and the replies:

Error Invoking REST Webservice deployed without any Authentication Settings

While trying to invoke a REST webservice that is deployed with Authentication set to None, getting the following Error **There was an error while generating this response: ** ** Authentication error: Local login authentication with domain not supported ** Can you help on what is causing this error and on steps to resolve the same and get the response from deployed Webservice ?
user
23-05-2018 08:43:26 -0400

2 Answers

Hi, I tried the same and it worked without problems. The authentication for Web Services published in the Denodo Platform happens on two different levels: First, you authenticate against the web service itself. You can configure this in the Settings tab of the a web service in Denodo. You can take a look at this section of the documentation: [Settings Tab (REST)](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/publication_of_web_services/publishing_rest_web_services/settings_tab_rest). Also, check the [Web Services Authentication](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/publication_of_web_services/web_services_authentication/web_services_authentication#authentication-methods-support-by-soap-and-rest-web-services) for a better understanding of the different authentication methods provided by Denodo. Second level is how the web service authenticates against the VDP Server. You can configure this when deploying a web service from the VDP Administration Tool. I’d recommend you to check both options again. This section of the VDP Administration Guide explains the different alternatives: [Web Service Container Status Table](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/publication_of_web_services/web_service_container_status_table/web_service_container_status_table) as well as [How Web Services Query the Virtual DataPort Server](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/publication_of_web_services/how_web_%20services_query_the_virtual_dataport_server/how_web_%20services_query_the_virtual_dataport_server). Further, I’d recommend to check if it works from another browser to discard it is a browser issue or any other client tool. Hope this helps!
Denodo Team
24-05-2018 07:13:27 -0400
Hi **Denodo Team**, Thank you so much for your quick response for my question. But i could not get past that error ( "Local login authentication with domain not supported"). I did try with different browsers to rule out client issues. Also, wanted to rule out any denodo access rights that might be contributing to this error. Is there any specific rights to be provided in denodo for a user to create and invoke webservice in Denodo Tool ? Let me know what other configuration or settings at denodo server level (if any) that we may have to check to get past this error and get webservices to work ? Thanks again
user
 Edited on: 12-09-2018 19:05:54 -0400
You must sign in to add an answer. If you do not have an account, you can register here