You can translate the question and the replies:

OData Authentication isue

I downloaded the OData wrapper and we are trying to connect to some lists we have in Sharepoint. I followed the instructions in this link: I was able to connect to one list in my service endpoint. I used the NTLM authentication and it even pulled the MetaData which tells me it connected. However, when I go to the execute panel and try to get the data it des not work. It gives me a 401 Not Authorized user error. That is strange since I can get the information of the metada. I know I have access to the Sharepoint server and to those lists specifically. So, that is not the problem. I can also create an XML datasource and connect that way to the list (we don't want to do this and would prefer the OData alternative). I checked the configuration of the server and it is configured to do Kerberos authentication; but this option does not exist in the OData wrapper so I chose NTLM (is that ok??) So, what else can I check?
24-07-2018 11:32:49 -0400

2 Answers

Hi, If the wrapper you downloaded from DenodoConnects was "OData 4 Custom Wrapper", the Readme.txt file includes the following: "The authentication using NTLM through a proxy is not supported". So that may be a possible issue. If you do use Kerberos, another place to check for Kerberos configuration is the Admin Tool. Per [this]( article, aside from configuring the server, the clients that want to login using Kerberos must be configured as well. So I would just check to see if the Admin tool is configured or not and adjust accordingly if necessary. If you have a support user account, you also have the option to open a case and have the support team look into this case in more detail. I hope this helps!
Denodo Team
24-07-2018 15:09:16 -0400
Thank you! Yes, I read that file and we are not using a proxy; so that is fine. I am actually using the Admin Tool and it is set up to work with Kerberos. So, that is not the issue either. If anyone has any other ideas, I'd appreciate the help. Thanks!
24-07-2018 15:53:49 -0400
You must sign in to add an answer. If you do not have an account, you can register here