You can translate the question and the replies:

Denodo base view times out in 15 minutes (Microsoft SQL Server 2014 (MS Driver))

Denodo Server times out when I try to access the base view that takes more than 15 minutes to execute. Since query timeouts are a client side concept only, I have already altered below settings on BOTH the clients: Admin Tool Preference -> Connection -> Query timeout(milliseconds) to ZERO. Admin -> Server Configuration -> Stored procedures -> Query timeout(milliseconds) to ZERO. As mentioned in the article, I have added queryTimeout parameter in JDBC connection string. (https://community.denodo.com/docs/html/browse/6.0/vdp/developer/access_through_jdbc/parameters_of_the_jdbc_connection_url/parameters_of_the_jdbc_connection_url) like jdbc:sqlserver://database_name:port_number;databaseName=xyz;queryTimeout=0 But it doesn’t work. Please provide exact syntax to extend queryTimeout in JDBC connection. Connection details are as follows: Datasource Configuration details are as follows: Database adapter: Microsoft SQL Server (MS Driver) Driver class path (optional): ‘sqljdbc41’ Driver Class: com.microsoft.sqlserver.jdbc.SQLServerDriver Database URI: jdbc:sqlserver://servername:port;databaseName=mydatabasename Login: loginname Password: pwd Transaction: Database default
user
30-07-2018 12:32:02 -0400

1 Answer

Hi, I’m not sure what you mean by both clients, you seem to have only posted settings for vdp. Referring to a similar previous post [here](https://community.denodo.com/answers/question/details?questionId=9060g0000000AVWAA2&title=Denodo+Base+view+times+out+in+15+minutes), you’ve already changed the timeouts in vdp. The provided syntax in that post of a context clause is the most direct manipulation of the timeout parameter. If you run the provided query in VQL shell, with the settings you’ve mentioned, and got the expected result of an immediate timeout, then timeout settings are taking effect, and vdp should not be what is timing out. In another previous question, [here](https://community.denodo.com/answers/question/details?questionId=9060g000000L6wdAAC&title=VDP+Query+timeout+is+automatically+goes+to+default+value+900000), and an article [here](https://community.denodo.com/kb/view/document/Connection%20using%20third%20party%20SQL%20clients?category=Northbound+Connections), they discuss changing the querytimeout parameter at the connection level. There is an error in your jdbc uri syntax for the parameters: jdbc:vdb://<host>:<port>/<database>?queryTimeout=100000 Is the correct syntax. But again this is for when connecting from a client *other* than the admin tool, to vdp, to dictate to vdp that vdp’s query timeout setting is to be overridden. You’ve already changed the settings to unlimited, this won’t have an impact. Hope this helps!
Denodo Team
03-08-2018 12:20:58 -0400
You must sign in to add an answer. If you do not have an account, you can register here