You can translate the question and the replies:

Group by condition failure with mysql database in Denodo 6.0

Hi, I am trying to create a derived view using group by condition with specific fields in denodo 6.0 with mysql database. There seems to be an issue with it. I am either getting communication link failure or it is atleast taking more than 2 minutes to execute the query. Please help.
user
01-08-2018 11:21:43 -0400

3 Answers

Hi, From the information you have provided, you could perform the following checks in Virtual DataPort Administration Tool: * You can check the Execution Trace to see what is causing the delay. After executing a query, you can select the Execution Trace option under the Query Results tab. * Ensure that you are connecting to MySQL Database via a JDBC connection instead of a ODBC connection. The reason is that in Virtual DataPort, queries involving a JDBC data source run faster than if they involve an ODBC data source, even if the underlying source is the same. You may refer to the [Execution Trace of Statement](https://community.denodo.com/docs/html/browse/6.0/vdp/administration/creating_views/querying_views/execution_trace_of_a_statement) and [JDBC Sources](https://community.denodo.com/docs/html/browse/6.0/vdp/administration/creating_views/importing_data_sources_and_creating_base_views/jdbc_sources) section of the Virtual DataPort Administration Guide for more information. Hope this helps!
Denodo Team
02-08-2018 04:04:54 -0400
Hi, Thanks for the reply. I have connected to MYSQL database via JDBC connection. In the execution trace i see that JDBC Route is taking more than 2 minutes and this is causing the delay. I am not knowing the cause. Please help me.
user
02-08-2018 11:59:26 -0400
Hi, You could utilize Query Optimization technique to reduce the delay of the queries. For this case, I would enable the Automatic simplification of queries in Server level by following this steps: * Go to the Administration tab of the Virtual DataPort Administration Tool > Server Configuration. * Select the Queries Optimization option. * Enable ‘Automatic Simplification of Queries’. You can also enable it on the Database level by Administration tab > Database management and ‘Edit’. You may refer to [Automatic Simplification of Queries](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/optimizing_queries/automatic_simplification_of_queries/automatic_simplification_of_queries#automatic-simplification-of-queries) section of the Virtual DataPort Administration Guide for more information different simplifications performed by Virtual DataPort Execution Engine. Hope this helps!
Denodo Team
10-08-2018 05:24:06 -0400
You must sign in to add an answer. If you do not have an account, you can register here