You can translate the question and the replies:

Can we run ODATA2.0 with ODATA4?

Hello, I have installed ODATA2.0 but I cannot connect to the database using the URL: http://localhost:9090/denodo-odata2-service-7.0/denodo-odata.svc/dbname I get a Error 405 if I just browse to http://localhost:9090/denodo-odata2-service-7.0/denodo-odata.svc I will get a "No service was found." message. I'm using Denodo version 7.0 and I can connect using ODATA4.0 http://localhost:9090/denodo-odata4-service/denodo-odata.svc/dbname Are these 2 versions compatible? can you please guide me on how to debug what is missing with the odata2? Thanks and regards, Sérgio
user
30-10-2018 11:51:57 -0400

1 Answer

Hello, Odata4 provides lot of performance and usability updates like new Search operator, metadata content filter etc. Denodo Platform 7.0 is Odata4 compliant data service and Odata2.0 is deprecated in Denodo Platform 7.0. You can upgrade the applications to OData 4.0 whenever possible and use the embedded Odata4.0 Data service for metadata/data service requests. Refer to the [Denodo OData 4.0 Service](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/restful_architecture/odata4_service/odata4_service) of Virtual DataPort Administartion Guide for more details on how to use the embedded OData4.0 Data Service. Hope this helps!
Denodo Team
07-11-2018 06:52:29 -0500
You must sign in to add an answer. If you do not have an account, you can register here