You can translate the question and the replies:

Error when using LIKE operator: URLDecoder: Illegal hex characters in escape (%) pattern

Hello, I am running into an issue when using the LIKE operator on my webservice. In order to make the like more effective, I have added a percent sign before and after the text I want to search on. This way I can bring back results that have my text anywhere within the result. Example, I am searching for records with "Mills" in them. I use "%Mills%" when querying their results. Here is my URL for my search: http://localhost:9090/server/phit/Reporting_Service/views/sv_report?$filter=%22Producer%22+like+%27%25Mills%25%27 And the full error message: There was an error while generating this response: URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "Mi" I really need the ability to search using wild cards. Please advise the best way to do this. Thanks, Nate
user
25-09-2017 12:44:54 -0400

4 Answers

Hi Nate, I tried using the following way and it worked for me. In your URL you don't have to specify the quotes as URL parameters and also use the correct representation of the value. For example in your case I would try is the following way: http://localhost:9090/server/phit/Reporting_Service/views/sv_report?$filter=Producer+like+'Mills' To know more about parameters read the section["Parameters of the RESTful Web Service"](https://community.denodo.com/docs/html/browse/6.0/vdp/administration/restful_architecture/restful_web_service/representations#parameters-of-the-restful-web-service) of the Virtual DataPort Administration Guide. Hope this helps.
Denodo Team
26-09-2017 06:45:55 -0400
This doesn't accomplish the appropriate search. Without the percent signs, it only looks for items that exactly match 'Mills' instead of items that have 'Mills' contained in it. In other words, searching without percents would show records like 'Mills' but not records like 'Mills Farms'. What wild character do I use when querying from the webservice? Thanks, Nate
user
26-09-2017 09:37:26 -0400
Hi, I'm running into the same issue. Did you ever get this resolved? Thanks, Kumaresh
user
20-12-2017 13:02:15 -0500
Hi, If you have valid support user , I recommend you to dowload the latest Denodo update from the https://support.denodo.com and install it. This is fixed in the latest update. In this new update the escape characters are handled as expected. Hope this helps.
Denodo Team
07-03-2018 05:26:20 -0500
You must sign in to add an answer. If you do not have an account, you can register here