You can translate the question and the replies:

Caching

Hi, I have partial caching enabled, and configuration is set on external database and allowed writing on the database. Also I exposed the view as a REST service. When I access the RET service it creates the table in the cache database but does not cache any data. I tried with exact query match option too. I do not have explict load checked. Do I need to explicitly load the cache by running a query? Shouldn't server automatically load the latest data into my cache? I'm using free version for my testing. Quick reply is highly appreciated, have to demo to my manager, thanks, Shreyash
user
01-06-2020 10:42:14 -0400

1 Answer

Hi, I was able to cache the data in the external database using Partial Cache mode over the view following below steps: * Configure partial cache mode over the view by navigating to Options > Cache tab in the view. * If required, select "Match exact queries only" option and save the view. * Publish the view as Rest web services. * Save and deploy the published web services. * Now, when I access the web service from the browser and when I click on the view, the results will be displayed. At the same time, data will be loaded in cache database. Please note that when you select Explicit Loads option under partial cache, you must load the cache manually using the Context clause with the below parameters: ``` ‘cache_preload’ = ‘true’ ‘cache_wait_for_load’=’true’ ``` **For Example:** `Select * from <view_name> where condition CONTEXT(‘cache_preload’ = ‘true’, ‘cache_wait_for_load’=’true’)` For more details about functionality of partial cache, you can refer to [Partial Mode](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/cache_module/cache_modes/partial_mode#explicit-loads) section of the Virtual DataPort Administration Guide which explains in detail about different cache options with examples. Hope this helps!
Denodo Team
02-06-2020 08:20:28 -0400
You must sign in to add an answer. If you do not have an account, you can register here