You can translate the question and the replies:

SQL Server date conversion error in BaseView

Hello Support Team We are having a big stopper in a project with an odd issue for which we can't find a way to solve it. Technical data is and Consultant has already raised the same question: * Source Server DataBase is SQLServer 2016. * SQL Server has Collation `SQL_Latin1_General_CP1_CI_AS` * Conflicting datatypes: datetime2, smalldatetyme ![SQL Server](https://live.staticflickr.com/65535/49994760828_5784714c19.jpg) Here's datatypes in conflict: ![Data Types](https://live.staticflickr.com/65535/49995534062_8b10d48e8a_n.jpg) Denodo VDP version is 7.0, has 20200310 update installed. Also VDP was installed with Internationalization configuration of: `mx` ![VDP_Installation](https://live.staticflickr.com/65535/49994760738_55baf78c71.jpg) Here's the base view: ![BaseView](https://live.staticflickr.com/65535/49994760773_03a105a2df_n.jpg) And the result: ![BaseViewExec](https://live.staticflickr.com/65535/49995534137_01d09fd59e_n.jpg) In base view I've tried every i18n option with no different result. Please provide your help or assitance.
user
11-06-2020 12:32:00 -0400

1 Answer

Hi, Based on the screenshots you have attached, it seems that you are showing the option to choose the locale on the installation of Solution Manager instead of the Virtual DataPort Administration Tool. However, I would still try to check the i18n option of the base view by opening the base view and going to Options > Search Methods. Check the Default i18n and see if the correct i18n has been selected. Also, the issue could be due to the version of the Microsoft SQL Server JDBC Driver. I would try to change the datasource configuration and connect using the driver available in the following directory: `<DENODO_HOME>/lib/extensions/jdbc-drivers/mssql-jdbc-6.x` Then recreate the base view to see if the issue it resolved. If the issue persists, I would recommend raising a case in the [Support Site](https://support.denodo.com/). Hope this helps!
Denodo Team
15-06-2020 04:02:11 -0400
You must sign in to add an answer. If you do not have an account, you can register here