You can translate the question and the replies:

trying to connect denodo using pyodbc

i have gone through the solution mentioned in the community, these are the parameters that i didn't get: denodoserver_name = "ubuntu1804-denodo7" odbcdriver = "DenodoODBCDriver-20200310" what i have to mention in place of the denodoser_name? the IP on which denodo is installed and in odbc path what to mention, i have already downloaded the i need to mention the file path or what? Please help.
19-06-2020 07:41:00 -0400

3 Answers

Hi, I see you are following the KB article on [How to connect to Denodo from Python - a starter for Data Scientists]( In this, the denodoserver_name is the name of your machine where the VDP Server is installed. If you do not have a SYSTEM NAME and you use the IP to connect to the VDP Server from any client like VDP Administration tool, you can definitely use the same IP Address over here as well. Additionally, if you are using **odbcdriver** parameter, then its a DSN less connection. Therefore, after downloading the driver, you would need to install the driver in your system first and then you can just provide the name of the driver installed in this parameter to use it in your code. For example: In Windows OS, you can just go to ODBC Data sources from the Start menu and Click the Drivers tab to see all the drivers installed. Hope this helps!
Denodo Team
22-06-2020 01:49:31 -0400
I did the same, but i am getting below error: InterfaceError: ('IM002', '[IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified (0) (SQLDriverConnect)')
 Edited on: 22-06-2020 07:50:12 -0400
Hi, It looks like you are trying to find the driver installed in the odbc sources in windows, maybe you are looking at the 32 bit one and have the driver installed of 64-bit. In other words, you need a 32-bit driver for a 32-bit application or a 64-bit driver for a 64-bit application. I would first check these configuration to find the driver installed. Hope this helps!
Denodo Team
30-06-2020 08:40:35 -0400
You must sign in to add an answer. If you do not have an account, you can register here