You can translate the question and the replies:

connection error.cannot trust in the server to establish a ssl connection

Hi Team, Iam facing this issue when trying to log in to VDP admin tool after installing self signed certs . can you please hellp in solving this issue and guide me do i n eed to do any chnages other then what i have done. changes made Changes Made: Generate and install a self-signed SSL certificate Generate new key pair in a key store "$DENODO_HOME/jre/bin/keytool" -genkeypair -alias self-signed -keyalg RSA -keysize 2048 -sigalg SHA1withRSA -keypass <key password> -keystore <keystore path *.jks> -storepass <keystore password> -storetype jks -validity 365 -dname "CN=<CommonName>,OU=<OrganizationalUnit>,O=<Organization>,L=<Locality>,ST=<StateOrProvinceName>,C=<CountryName>" Export self-signed certificate "$DENODO_HOME/jre/bin/keytool" -exportcert -alias self-signed -keystore <keystore path *.jks> -storepass <keystore password> -file <self-signed certificate path *.cer> Import self-signed certificate into TrustStore "$DENODO_HOME/jre/bin/keytool" -importcert -alias self-signed -file <self-signed certificate path *.cer> -keystore "$DENODO_HOME/jre/lib/security/cacerts" -storepass changeit Uncomment and change properties in these files: $DENODO_HOME/conf/vdp/VDBConfiguration.properties com.denodo.security.ssl.enabled=true com.denodo.security.ssl.keyStore=<client keystore path *.jks> com.denodo.security.ssl.keyStorePassword=<client keystore password> com.denodo.security.ssl.trustStore=$DENODO_HOME/jre/lib/security/cacerts $DENODO_HOME/conf/vdp-admin/VDBAdminConfiguration.properties com.denodo.security.ssl.trustStore=$DENODO_HOME/jre/lib/security/cacerts $DENODO_HOME/resources/apache-tomcat/conf/tomcat.properties com.denodo.tomcat.https.port=9443 com.denodo.security.ssl.enabled=true com.denodo.security.ssl.keyStore=<client keystore path *.jks> com.denodo.security.ssl.keyStorePassword=<client keystore password> com.denodo.security.ssl.trustStore=$DENODO_HOME/jre/lib/security/cacerts com.denodo.security.ssl.trustStorePassword=changeit Comment the non-SSL Connector and uncomment the SSL Connector in the file $DENODO_HOME/resources/apache-tomcat/conf/server.xml (server.xml.template for Denodo versions previous to 6.0) <!-- Define a non-SSL HTTP/1.1 Connector --> <!--<Connector port="${com.denodo.tomcat.http.port}" … />--> <!-- Define a SSL HTTP/1.1 Connector on port 8443 --> <Connector port="${com.denodo.tomcat.https.port}" … /> Thanks, Sagar
user
02-02-2018 06:13:02 -0500

3 Answers

Hi, This question seems to be duplicated. You can find the answer for this question in the below community link: [connection error.cannot trust in the server to establish a ssl connection when connecting to VDP admin tool after installing certs](https://community.denodo.com/answers/question/details?questionId=9060g000000L71TAAS&title=connection+error.cannot+trust+in+the+server+to+establish+a+ssl+connection+when+connecting+to+VDP+admin+tool+after+installing+certs) Hope this helps!!
Denodo Team
05-02-2018 07:59:33 -0500
Hi, I am facing an issue after successfully implementing the SSL. When i am running the web tools such as scheduler/data catalog browser or restful web services with the https://localhost:9443/denodo-restfulws/admin, it is giving **NOT SECURE error- NET::ERR_CERT_COMMON_NAME_INVALID.** I have imported the certificate in the Trusted Root Certification Authorities, still it is giving the same error Please advice! Thanks.
user
19-06-2019 08:44:14 -0400
Hi, This error could have occured due to the name mismatch in the SSL certificate. In order to overcome this error, I would perform the following checks and try again to access the web page * Ensure that the domain name has the correct certificate installed also make sure that the common name for the cert is correct. * Clear the cache and cookies from the browser from which the webtools are accessed. * Ensure that no firewall is blocking the connection * Make sure that the date and time in your system is correct. Hope this helps!
Denodo Team
03-07-2019 09:05:02 -0400
You must sign in to add an answer. If you do not have an account, you can register here