You can translate the question and the replies:

Connection Error (Service Negotiation failed) with the creation of ODBC 32 bits data source

Hi We're trying to create ODBC data sources to Denodo on a Windows Server. The Datasource 64 bits is working fine. But we have a connection error for the 32 bits one. The connection test (with SSL mode=require) gives : Service Negotiation failed;The message received was unexpected or badly formatted. in DoSchannelNegotiation:PerformSchannelClientHandshake Our Denodo version is 6.0 20190422 The DenodoODBC driver version is 9.03.04.23 Here are the informations about Windows server where we want to create an ODBC 32 bits : Host Name: CENSURE OS Name: Microsoft Windows Server 2016 Standard OS Version: 10.0.14393 N/A Build 14393 OS Manufacturer: Microsoft Corporation OS Configuration: Member Server OS Build Type: Multiprocessor Free Registered Owner: BNPPIP Registered Organization: BNPPIP Product ID: 00377-60000-00000-AA934 Original Install Date: 2/21/2018, 8:11:25 AM System Boot Time: 11/30/2019, 3:21:53 AM System Manufacturer: VMware, Inc. System Model: VMware Virtual Platform System Type: x64-based PC Processor(s): 8 Processor(s) Installed. [01]: Intel64 Family 6 Model 79 Stepping 1 GenuineIntel ~2098 Mhz [02]: Intel64 Family 6 Model 79 Stepping 1 GenuineIntel ~2098 Mhz [03]: Intel64 Family 6 Model 79 Stepping 1 GenuineIntel ~2098 Mhz [04]: Intel64 Family 6 Model 79 Stepping 1 GenuineIntel ~2098 Mhz [05]: Intel64 Family 6 Model 79 Stepping 1 GenuineIntel ~2098 Mhz [06]: Intel64 Family 6 Model 79 Stepping 1 GenuineIntel ~2098 Mhz [07]: Intel64 Family 6 Model 79 Stepping 1 GenuineIntel ~2098 Mhz [08]: Intel64 Family 6 Model 79 Stepping 1 GenuineIntel ~2098 Mhz BIOS Version: Phoenix Technologies LTD 6.00, 9/21/2015 Windows Directory: C:\Windows System Directory: C:\Windows\system32 Boot Device: \Device\HarddiskVolume1 System Locale: en-us;English (United States) Input Locale: en-us;English (United States) Time Zone: (UTC+01:00) Brussels, Copenhagen, Madrid, Paris Total Physical Memory: 32,768 MB Available Physical Memory: 25,534 MB Virtual Memory: Max Size: 34,816 MB Virtual Memory: Available: 27,278 MB Virtual Memory: In Use: 7,538 MB Page File Location(s): C:\pagefile.sys Domain: adroot.local Logon Server: \\CENSURE Hotfix(s): 13 Hotfix(s) Installed. [01]: KB3199986 [02]: KB4033393 [03]: KB4035631 [04]: KB4132216 [05]: KB4465659 [06]: KB4485447 [07]: KB4498947 [08]: KB4503537 [09]: KB4509091 [10]: KB4512574 [11]: KB4520724 [12]: KB4521858 [13]: KB4525236 Network Card(s): 2 NIC(s) Installed. [01]: vmxnet3 Ethernet Adapter Connection Name: OOB DHCP Enabled: No IP address(es) [01]: CENSURE [02]: vmxnet3 Ethernet Adapter Connection Name: PROD DHCP Enabled: No IP address(es) [01]: CENSURE Hyper-V Requirements: A hypervisor has been detected. Features required for Hyper-V will not be displayed.
user
02-12-2019 09:15:26 -0500

2 Answers

Hi, I have experienced the same problem when I have forgotten to set the use of LIBPQ library to ‘yes’ on the Page 3 of the ODBC Datasource configuration. I would review every step on the article about [Set Up a DSN on Windows](https://community.denodo.com/docs/html/browse/6.0/vdp/developer/access_through_odbc/configuration_of_the_odbc_driver_on_windows/set_up_a_dsn_on_windows) just to make sure that every option is set as needed. Hope this helps!
Denodo Team
02-12-2019 18:11:42 -0500
Hi, We've already tested with "use of LIBPQ library" to ‘yes’ and we receive the same error. Any idea ? In which way do we have to investigate ?
user
03-12-2019 04:31:10 -0500
You must sign in to add an answer. If you do not have an account, you can register here