You can translate the question and the replies:

Denodo Express 7.0 installation Failed on MacOs Catalina

Hi, I have downloaded Denodo Express 7.0 to my Macbook which is running on MacOs Catalina.I have installed JDK 1.8 and assigned $JAVA_HOME to "/Library/Java/JavaVirtualMachines/jdk1.8.0_231.jdk/Contents/Home" in .zshrc file. When i run the command ***bash install.sh*** from the folder **/Users/mcac/downloads/denodo-install-7.0**, its giving below error. Please help me to resolve this error. Error: ---- readlink: illegal option -- f usage: readlink [-n] [file ...] install.sh: line 10: /Users/mcac/downloads/denodo-install-7.0/jre/bin/java: cannot execute binary file
user
13-12-2019 15:14:03 -0500

2 Answers

Hi, Denodo Express 7.0 is currently supported on Windows, Linux, and Solaris. However, to install Denodo Express 7.0 on Mac, I would make sure to do the following: * Download the **Generic (no JRE)** version of [Denodo Express 7.0](https://community.denodo.com/express/download). * Download the Java 1.8 JDK since this is the version of the internal JVM that Denodo Express 7.0 runs on. * Set up the [JAVA_HOME and PATH variables](https://docs.oracle.com/cd/E19182-01/820-7851/inst_cli_jdk_javahome_t/). For example: * JAVA_HOME= <jdk-install-dir> You should be able to run "install.sh" after properly configuring everything. You may find the following Community Q&A topics useful: * [Denodo installation requirements and bootstrapping section](https://community.denodo.com/answers/question/details?questionId=9060g000000XewQAAS&title=Denodo+installation+requirements+and+bootstrapping+section) * [mac support 64 bir](https://community.denodo.com/answers/question/details?questionId=90670000000CcBPAA0&title=mac+support+64+bir) Hope this helps!
Denodo Team
13-12-2019 18:43:44 -0500
Hi, I ran into the same issue. Here are the potential fixes: **Type one: jre mismatch issue** The install.sh is sets the java home to `JAVA_HOME=pwd/jre` This jre is the one that is located within the denodo-install-7.0 zip that you would have downloaded. Navigate to the jre directory and execute this command on the terminal: ``` cat release JAVA_VERSION="1.8.0_162" OS_NAME="Windows" OS_VERSION="5.1" OS_ARCH="i586" ``` If it says, OSNAME is Windows, then rename the jre directory to jre_unused and make sure you have set your Java home properly by using the command below: `export JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"` **Type 2: Arch mismatch** Make sure your system and java architecture is the same.
user
29-01-2020 06:06:23 -0500
You must sign in to add an answer. If you do not have an account, you can register here