You can translate the question and the replies:

Why do JDBC escape sequences give an error with the Denodo JDBC driver?

We are using SAP Business Objects Xi 4.2 to consume data from Denodo 7.0 using the Denodo JDBC driver. However queries generated by Business Objects that use a filter on a date object return an error. The SQL is generated with the following syntax in the where clause (see example below): WHERE view_a.column_b IN ( {d '2020-01-06'} ) We see from the KB article: https://community.denodo.com/kb/view/document/How%20to%20access%20VDP%20from%20SAP%20BusinessObjects?category=Northbound+Connections that denodo reccomend changing the date format property in the vdp.prm file. So we have set the property as follows; <Parameter Name="USER_INPUT_DATE_FORMAT">'dd-MMM-yyyy HH:mm:ss'</Parameter> 'dd-MMM-yyyy HH:mm:ss' is the same as the datepattern in the gb i18n map (which is the default i18n in the denodo server). Applying this change to the vdp.prm file stops the {d } escape sequence appearing in the SQL and looks like it does solve our problem. ....So our question is: Why do escape sequences like {d '2020-01-06'} cause an error in denodo? The {d '2020-01-06'} syntax appears to be a valid JDBC standard and we have noticed it works ok in other JDBC drivers; e.g. Postgres, Oracle etc. So we wondering why it does not work for Denodo.
user
16-01-2020 11:43:19 -0500

1 Answer

Hi, I was able to reproduce the behavior you are experiencing. The reason that Virtual DataPort does not allow the use of JDBC escape sequences comes down to the JDBC driver used by Denodo Platform, which does not support such escape sequences. If you have a valid [Support](https://support.denodo.com/) account, then you can create a support case to request this feature. Hope this helps!
Denodo Team
23-01-2020 13:07:55 -0500
You must sign in to add an answer. If you do not have an account, you can register here