You can translate the question and the replies:

Date Range parameter doesn't accept date

Hi, I am doing the denodo on demand training. One chapter has this excersize 'DEN70EDUD1102LAB02 - Create a Delimited File data source using DateRange function" The file saved in my local directory as below 20160101 20160102 20160103 20160104 20160105 20160106 20160107 I am creating the connection. I am giving the right path as i have put the detail like below File paht: Filepath/^DateRange("yyyy/MM/dd",@start_date,@end_date,"yyyyMMdd") File name pattern: (.)\.log now the problem is when i hit test connection it asked me to put start date and end date and i put in every format but it doesn't accept Start Date: '20160101' or '2016-01-01' or '2016/01/01' Start Date: '20160107' or '2016-01-07' or '2016/01/07' i tried put the date in various format but didn't work. any idea what am i doing wrong? Thanks Shahroz Ahmed

1 Answer

Hi, When I tried to create a Delimited File data source using the DateRange function, I was able to create it successfully by following the below steps, * Provide the File path as "{Path to the files}/^DateRange(…).log". * Click on Test connection. * Ensure the interpolation variable sequence which is, > END_DATE: 2016/01/07 > START_DATE: 2016/01/01 * Again click on Test Connection, the connection establishes successfully. For more information, you could refer to the instructions provided in the lab description "**DEN70EDUD1102LAB02 - Create a Delimited File data source using DateRange function**". Hope this helps!
Denodo Team
10-02-2020 05:50:58 -0500
You must sign in to add an answer. If you do not have an account, you can register here