You can translate the question and the replies:

Context clause wiped out by VDP....

I created a new derived view from a base view and provided the context for 'queryTimeout' setting e.g. ``` SELECT ... FROM ... CONTEXT ('queryTimeout' = '9000000') ``` However, VDP keeps replacing it with ``` SELECT ... FROM ... CONTEXT ('formatted' = 'yes') ``` How can I make it take my input? I'm using Denodo Virtual DataPort version 7.0.20190903.
user
26-02-2020 21:37:06 -0500

1 Answer

Hi, Query timeout is a parameter that is set for the connection level configuration and not for the view level. The reason it's getting replaced with *CONTEXT ('formatted' = 'yes')* is that the administration tool automatically adds this parameter when you manually edit the VQL of a derived view using the [VQL tab](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/creating_data_sources_and_base_views/viewing_the_schema_of_a_base_view/viewing_the_schema_of_a_base_view#view-the-vql-of-an-element). So, the *queryTimeout* parameter can be used while executing rather than while creating or altering a view. I came across these two ways to set the parameter: * Under Tools-->Admin Tool preferences-->Connection -->Query Timeout, you can set the value. * When accessing via JDBC clients, optionally the *queryTimeout *parameter can be set by setting the value in the JDBC connection URL. You may refer to [Parameters of the JDBC Connection URL](https://community.denodo.com/docs/html/browse/7.0/vdp/developer/access_through_jdbc/parameters_of_the_jdbc_connection_url/parameters_of_the_jdbc_connection_url) of the Virtual DataPort Developer Guide and [CONTEXT Clause](https://community.denodo.com/docs/html/browse/6.0/vdp/vql/queries_select_statement/context_clause/context_clause#syntax-of-the-context-clause) of the Virtual Dataport VQL guide for more information. Hope this helps!
Denodo Team
27-02-2020 07:29:05 -0500
You must sign in to add an answer. If you do not have an account, you can register here