You can translate the question and the replies:

java.lang.NoClassDefFoundError while trying to connect to hive

hello, i have a problem concerning connecting to hive database. i have denodo virtual dataPort version 7 and the quickstart cloudera vm with cloudera version 1.1 .0 but everytime i try to test the connection the following error appears Unable to establish connection: java.lang.NoClassDefFoundError: Could not initialize class com.cloudera.hive.jdbc42.internal.apache.thrift.transport.TSocket screenshots: ![https://www.photobox.co.uk/my/photo/full?photo_id=502742686374](http://) [https://www.photobox.co.uk/my/photo/full?photo_id=502742686374](http://) ![https://www.photobox.co.uk/my/photo/full?photo_id=502742698056](http://) [https://www.photobox.co.uk/my/photo/full?photo_id=502742698056](http://) any help would be apperciated. thanks and have a nice day.

1 Answer

Hi, This error *java.lang.NoClassDefFoundError: Could not initialize class*, could occur when the driver used to connect to the hive database, does not include the necessary dependencies. Hence, I would copy the driver along with its dependencies under the *<DENODO_HOME>\lib-external\jdbc-drivers\hive-1.1.0-cloudera* folder to overcome this error. You can refer to [Supported JDBC Data Sources](https://community.denodo.com/docs/html/browse/7.0/vdp/administration/appendix/supported_jdbc_data_sources/supported_jdbc_data_sources) section of the Virtual DataPort Administration Guide for more information. Hope this helps!
Denodo Team
03-03-2020 07:37:34 -0500
You must sign in to add an answer. If you do not have an account, you can register here