You can translate the question and the replies:

Not able to off the execution plan

Hi, I have created a derived view dv1 and on top of that i have created another derived view dv2. Now the problem is i did specify execution plan in dv2 from options tab. But as soon as i off the specify execution plan and open it again it automatically show me old value. what i mean is it does not let me off the specified execution plan. as soon as i off it and then save it and open it again. it again shows me old value . please help Regards Salman Khan
user
17-03-2020 03:34:51 -0400

1 Answer

Hi, The error is due to a known issue and it will be fixed in the next official update of the Denodo Platform. Meanwhile as a workaround, I would try the following steps: 1. Navigate to the VQL tab of the view for which you want to disable the execution plan. 1. Copy the entire VQL and open the *Tools* → *VQL Shell*. 1. Past the copied VQL and remove the *CONTEXT* clause part of the query at the end, you should see something like below: * *CONTEXT (QUERYPLAN = ....* 1. Then, execute the modified VQL (after performing the ***#3***) which will replace the existing view without any execution plan. Hope this helps!
Denodo Team
18-03-2020 05:51:17 -0400
You must sign in to add an answer. If you do not have an account, you can register here